+ Reply to Thread
Page 1 of 4 1234 LastLast
Results 1 to 10 of 37

Thread: SM-100 on my ELOS 120

  1. #1

    Join Date
    Feb 2011
    Location
    Sweden
    Posts
    87

    SM-100 on my ELOS 120

    Previously I have built a DIY scrubber for my new 600 liter reef tank which sofar is a success. But I also have a one year old Elos 120 reef tank. This tank is pretty mature and all the corals are thriving, I have had one Acro showing signs of burnt tips which can be due to too much biopellets. After reducing the amount of Biopellets and increasing the dosing of Amino acids all corals really look their best, but now I have gotten into a fight with some sort of green cyano.

    I have tried to build a DIY scrubber for this tank aswell but i didn't come out so well so I decided to try a SM-100. I ordered it and about a month later I recieved it in my local post office outside of Stockholm, Sweden. The box was a bit scuffed and looked like it had travelled around half the world (which it had) but the packaging was really exellent and everything was in very good condition.

    The build quality is 100% good, very very nice indeed.

    I'll post some pictures later, both of the install in the sump, but also of my green cyano infested tank. It's going to be interesting to see if it clears up!

  2. #2

    Join Date
    Feb 2010
    Location
    USA
    Posts
    59

    Re: SM-100 on my ELOS 120

    Cant wait to see pics of the setup .
    75RR / 20g sump / DIY Scrubber / 3 x 150DE MH & single T5 actinic

  3. #3

    Join Date
    Feb 2011
    Location
    Sweden
    Posts
    87

    Re: SM-100 on my ELOS 120



    My messy sump cabinet.. I took away the upper frame on the sump to get a better placement of the ATS.

  4. #4
    Administrator
    Join Date
    Oct 2008
    Location
    Santa Monica, CA, USA
    Posts
    9,957

    Re: SM-100 on my ELOS 120

    Good job fitting it in there

  5. #5

    Join Date
    Feb 2011
    Location
    Sweden
    Posts
    87

    Re: SM-100 on my ELOS 120

    A bit tight but it fits quite good I think! since I added the extra bit of tubing is virtually soundless!

  6. #6

    Join Date
    Feb 2011
    Location
    Sweden
    Posts
    87

    Re: SM-100 on my ELOS 120

    This is two days of growth! On a brand new media.. Green all over! It's sick!!!

  7. #7

    Join Date
    Feb 2011
    Location
    Sweden
    Posts
    87

    Re: SM-100 on my ELOS 120


    This is first 7 days of growth. The tank is quite mature and N & P are pretty low. I don't know if this is all right or not for the first week.

  8. #8
    Administrator
    Join Date
    Oct 2008
    Location
    Santa Monica, CA, USA
    Posts
    9,957

    Re: SM-100 on my ELOS 120

    Seems about perfect.

  9. #9

    Join Date
    Feb 2011
    Location
    Sweden
    Posts
    87

    Re: SM-100 on my ELOS 120

    Three days after first cleaning I can report that the growth looks massive. It's gonna be exiting to clean it on saturday.

  10. #10

    Join Date
    Feb 2011
    Location
    Sweden
    Posts
    87

    Re: SM-100 on my ELOS 120

    I spy with my little eye - 3D growth!

+ Reply to Thread
Page 1 of 4 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts